 <!DOCTYPE html>
<!--[if lt IE 7]>
<html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>
<html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>
<html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!-->
<html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="cache-control" content="no-cache">
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<title>The funniest #FloridaMorons tweets, as Florida&#039;s beaches reopened</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="//gmpg.org/xfn/11">
<link rel="pingback" href="https://photos.orlandoweekly.com/xmlrpc.php">

<link rel="shortcut icon" href="https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/favicon.orlandoweekly.ico">

<style type="text/css">
		a,
		div#HeaderforCategoryorSection h1,
		.jThumbnailScroller .jTscrollerNextButton:hover,
		.jThumbnailScroller .jTscrollerPrevButton:hover,
		.jThumbnailScroller .jTscroller a:hover,
		.footerCustomLogin ul li a,
		.footerCustomNav ul li a,
		.back-to-slider a:hover,
		.navbar-default .navbar-toggle:focus,
		.navbar-default .navbar-toggle:hover,
		.gallery-item h2 a,
		.categories a {
			color: #F7941E;
		}

		.slide-nav span,
		#crumbs,
		.page-navigation, .wp-prev-next {
			background: #F7941E;
		}

		.gallery-item h2 a:hover,
		.categories a:hover {
			color: #FF9534;
		}

		.bones_page_navi li a:hover,
		.bones_page_navi li a:focus,
		.bones_page_navi li.bpn-current,
		.bones_page_navi li.bpn-prev-link a:hover,
		.bones_page_navi li.bpn-next-link a:hover,
		.bones_page_navi li.bpn-first-page-link a:hover,
		.bones_page_navi li.bpn-last-page-link a:hover {
			background: #FF9534;
		}

		.navbar-default .navbar-toggle:focus,
		.navbar-default .navbar-toggle:hover {
			background: #F7941E !important;;
		}

		.slide-nav span:hover {
			background: #FF9534;
		}

		@media (max-width: 600px) {
			.main-navigation {
				background: #F7941E;
			}
		}
		
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            background-color: #000000 !important;
            border-color: #000000 !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            background-color: transparent !important;
            border-color: #000000 !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
            color: #000000 !important;
        }
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            color: #ffffff !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            color: #000000 !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #ee1c25 !important;
            border-color: #ee1c25 !important;
        }
        .qc-cmp-small-toggle,
        .qc-cmp-toggle {
            background-color: #C0C0C0 !important;
            border-color: #C0C0C0 !important;
        }
	</style>


<meta name="description" content="With more coronavirus cases than ever before, some Florida cities like Jacksonville reopened their beaches, leading to #FloridaMorons trending on Twitter." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The funniest #FloridaMorons tweets, as Florida&#039;s beaches reopened" />
<meta property="og:description" content="With more coronavirus cases than ever before, some Florida cities like Jacksonville reopened their beaches, leading to #FloridaMorons trending on Twitter." />
<meta property="og:url" content="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/" />
<meta property="og:site_name" content="Orlando Weekly Photo Galleries" />
<meta property="article:author" content="https://www.facebook.com/orlandoweekly" />
<meta property="article:tag" content="coronavirus" />
<meta property="article:tag" content="COVID-19" />
<meta property="article:tag" content="Florida Morons" />
<meta property="article:tag" content="FloridaMorons" />
<meta property="article:tag" content="floriduh" />
<meta property="article:tag" content="Jacksonville" />
<meta property="article:tag" content="trending" />
<meta property="article:tag" content="Twitter" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-04-19T19:36:28+00:00" />
<meta property="og:image" content="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg" />
<meta property="og:image:secure_url" content="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="591" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://photos.orlandoweekly.com/#website","url":"https://photos.orlandoweekly.com/","name":"Orlando Weekly Photo Galleries","inLanguage":"en-US","potentialAction":[{"@type":"SearchAction","target":"https://photos.orlandoweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/#primaryimage","inLanguage":"en-US","url":"https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg","width":1024,"height":591},{"@type":"WebPage","@id":"https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/#webpage","url":"https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/","name":"The funniest #FloridaMorons tweets, as Florida&#039;s beaches reopened","isPartOf":{"@id":"https://photos.orlandoweekly.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/#primaryimage"},"datePublished":"2020-04-19T19:36:28+00:00","dateModified":"2020-04-19T19:36:28+00:00","author":{"@id":"https://photos.orlandoweekly.com/#/schema/person/199f49de7c4adc6b5cfc44061cb0d1eb"},"description":"With more coronavirus cases than ever before, some Florida cities like Jacksonville reopened their beaches, leading to #FloridaMorons trending on Twitter.","potentialAction":[{"@type":"ReadAction","target":["https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/"]}]},{"@type":["Person"],"@id":"https://photos.orlandoweekly.com/#/schema/person/199f49de7c4adc6b5cfc44061cb0d1eb","name":"erin","image":{"@type":"ImageObject","@id":"https://photos.orlandoweekly.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e7700501562467a61fd403b0e35a9cdf?s=96&d=mm&r=g","caption":"erin"},"sameAs":["https://www.facebook.com/orlandoweekly"]}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly Photo Galleries &raquo; Feed" href="https://photos.orlandoweekly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly Photo Galleries &raquo; Comments Feed" href="https://photos.orlandoweekly.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/photos.orlandoweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='socialite-css-css' href='https://photos.orlandoweekly.com/wp-content/plugins/wpsocialite/lib/wpsocialite.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://photos.orlandoweekly.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpba_front_end_styles-css' href='https://photos.orlandoweekly.com/wp-content/plugins/wp-better-attachments/assets/css/wpba-frontend.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-style-css' href='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/css/bootstrap.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-theme-style-css' href='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/css/bootstrap-theme.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-style-css' href='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/css/font-awesome.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='montserrat-css' href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='lato-css' href='//fonts.googleapis.com/css?family=Lato%3A400italic%2C400%2C700%2C700italic&#038;ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css' href='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/css/main.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-basic-style-css' href='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/style.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='slider-css-css' href='https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/css/slider.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/js/vendor/modernizr.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/js/vendor/respond.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/js/vendor/html5shiv.js?ver=5.4'></script>
<link rel='https://api.w.org/' href='https://photos.orlandoweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://photos.orlandoweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://photos.orlandoweekly.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4" />
<link rel='shortlink' href='https://photos.orlandoweekly.com/?p=221998' />
<link rel="alternate" type="application/json+oembed" href="https://photos.orlandoweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphotos.orlandoweekly.com%2Fthe-funniest-floridamorons-tweets-as-floridas-beaches-reopened%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://photos.orlandoweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphotos.orlandoweekly.com%2Fthe-funniest-floridamorons-tweets-as-floridas-beaches-reopened%2F&#038;format=xml" />

<script async='async' src='//securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>
<script>
		googletag.cmd.push( function () {
			DesktopNativeEndOfArticle = googletag.defineOutOfPageSlot('/43707298/ORL_DesktopNative', 'div-gpt-ad-orl_desktopnative-3').setTargeting('media', ['screen']).setTargeting('oop', ['native-EndOfArticle']).addService(googletag.pubads());Top = googletag.defineSlot('/43707298/ORL_728x90', [728, 90], 'div-gpt-ad-orl_728x90-1').setTargeting('media', ['screen']).setTargeting('placement', ['ATF']).addService(googletag.pubads());setInterval( function() {if ( jQuery("#div-gpt-ad-orl_728x90-1").length > 0 ) {googletag.pubads().refresh([Top, Middle] );}}, 30000 );Top3 = googletag.defineSlot('/43707298/ORL_970x90', [[970, 90], [970, 250]], 'div-gpt-ad-orl_970x90').setTargeting('media', ['screen']).setTargeting('placement', ['ATF']).addService(googletag.pubads());setInterval( function() {if ( jQuery("#div-gpt-ad-orl_970x90").length > 0 ) {googletag.pubads().refresh([Top3] );}}, 30000 );Middle = googletag.defineSlot('/43707298/ORL_300x250', [300, 250], 'div-gpt-ad-orl_300x250-1').setTargeting('media', ['screen']).setTargeting('placement', ['ATF']).addService(googletag.pubads());Middle1 = googletag.defineSlot('/43707298/ORL_300x250', [[300, 250], [300, 600]], 'div-gpt-ad-orl_300x250-2').setTargeting('media', ['screen']).setTargeting('placement', ['BTF']).addService(googletag.pubads());Bottom = googletag.defineSlot('/43707298/ORL_728x90', [728, 90], 'div-gpt-ad-orl_728x90-2').setTargeting('media', ['screen']).setTargeting('placement', ['BTF']).addService(googletag.pubads());Position1 = googletag.defineSlot('/43707298/ORL_300x250', [300, 250], 'div-gpt-ad-orl_300x250-3').setTargeting('media', ['screen']).setTargeting('placement', ['Slideshowinline']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.pubads().collapseEmptyDivs();googletag.pubads().setTargeting( 'template', [ 'slideshow' ] ).setTargeting( 'oid', [] );googletag.pubads().setTargeting('vertical', ['news']).setTargeting( 'category', [] );googletag.enableServices();		} );

	</script>
<script src="//connect.facebook.net/en_US/all.js#appId=282729121836019&amp;xfbml=1" type='text/javascript'>
	</script>

<script>
		(function ( i, s, o, g, r, a, m ) {
			i[ 'GoogleAnalyticsObject' ] = r;
			i[ r ] = i[ r ] || function () {
					(i[ r ].q = i[ r ].q || []).push( arguments )
				}, i[ r ].l = 1 * new Date();
			a = s.createElement( o ),
				m = s.getElementsByTagName( o )[ 0 ];
			a.async = 1;
			a.src = g;
			m.parentNode.insertBefore( a, m )
		})( window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga' );
		ga( 'create', "UA-585470-1", 'auto' );
	</script>

<script type='text/javascript'>
		var vertical_name = "news";
		var vertical_title = "slideshow";
		var slide_prefix = "?slide";
		var slide_separator =  "=";
		var slide_name_separator =  "&";
		var slide_title =  "?slide=";
		var gtm_id = "GTM-KQ22CZ";
		var slideshow_ad_position = "div-gpt-ad-orl_300x250-3";
	</script>

<script>(function ( w, d, s, l, i ) {
			w[ l ] = w[ l ] || [];
			w[ l ].push( {
				'gtm.start': new Date().getTime(), event: 'gtm.js'
			} );
			var f = d.getElementsByTagName( s )[ 0 ],
				j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
			j.async = true;
			j.src =
				'//www.googletagmanager.com/gtm.js?id=' + i + dl;
			f.parentNode.insertBefore( j, f );
		})( window, document, 'script', 'dataLayer', gtm_id );</script>

</head>
<body class="post-template-default single single-post postid-221998 single-format-standard">

<noscript>
	<iframe src="//www.googletagmanager.com/ns.html?id=" +gtm_id
	        height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>

<!--[if lt IE 8]>
<p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade
	your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to
	improve your experience.</p>
<![endif]-->
<div class="container page-container">
<header role="banner">
<div class="row row-with-vspace site-branding">
<div class="col-md-4 site-title">
<h1 class="site-title-heading">
<a href="//www.orlandoweekly.com" title="Orlando Weekly" rel="home">
<img src="https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/img/logo.orlandoweekly.250.png" border="0" alt="Orlando Weekly home page." />
</a>
</h1>
</div>
<div class="col-md-8 page-header-top-right">
<div class="sr-only">
<a href="#content" title="Skip to content">Skip to content</a>
</div>
<div class="pull-right">
<div id="div-gpt-ad-orl_728x90-1"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_728x90-1'); });</script></div> </div>
<div class="clearfix">
</div>
</div>
</div>
<div class="row main-navigation">
<div class="col-md-12">
<nav class="navbar navbar-default" role="navigation">
<div class="navbar-header">
<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-primary-collapse">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a href="//www.orlandoweekly.com" target="_blank"><img src="https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/img/logo.orlandoweekly.mobile.png" class="mobile-logo"></a>
<h1 class="site-title">Slideshows</h1>
</div>
<div class="collapse navbar-collapse navbar-primary-collapse">
<ul id="menu-main" class="nav navbar-nav"><li id="menu-item-103089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103089"><a href="http://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408">News</a></li>
<li id="menu-item-103090" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103090"><a href="http://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407">Arts</a></li>
<li id="menu-item-103091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103091"><a href="http://www.orlandoweekly.com/orlando/music/Section?oid=2240410">Music</a></li>
<li id="menu-item-103092" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103092"><a href="http://www.orlandoweekly.com/orlando/screens/Section?oid=2240411">Screens</a></li>
<li id="menu-item-103093" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103093"><a href="http://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409">Food &#038; Drink</a></li>
<li id="menu-item-103094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103094"><a href="http://www.orlandoweekly.com/orlando/EventSearch">Calendar</a></li>
<li id="menu-item-103095" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103095"><a href="http://www.orlandoweekly.com/orlando/BestOf">Best of Orlando</a></li>
<li id="menu-item-103097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103097"><a href="http://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413">Special Issues</a></li>
<li id="menu-item-103099" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-103099"><a href="http://photos.orlandoweekly.com/">Galleries</a></li>
<li id="menu-item-103100" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103100"><a href="http://www.orlandoweekly.com/orlando/FreeStuff">Giveaways</a></li>
<li id="menu-item-103101" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103101"><a href="http://www.orlandoweekly.com/orlando/FreeStuff?category=2273894">OW Events</a></li>
</ul> </div>
</nav>
</div>
</div>
<div class="billboard"><div id="div-gpt-ad-orl_970x90"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_970x90'); });</script></div></div>
</header>
<div id="content" class="row row-with-vspace site-content"><div class="col-md-8 content-area" id="main-column">
<main id="main" class="site-main" role="main">
<h1 class="single-title" itemprop="headline">The funniest #FloridaMorons tweets, as Florida&#8217;s beaches reopened</h1>
<div class="photo-slider-container">
<div id="social_browser">
<div class="social 1" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=1&screen-shot-2020-04-19-at-1-30-38-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=1&screen-shot-2020-04-19-at-1-30-38-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=1&screen-shot-2020-04-19-at-1-30-38-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=1&screen-shot-2020-04-19-at-1-30-38-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 2" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=2&screen-shot-2020-04-19-at-1-27-48-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=2&screen-shot-2020-04-19-at-1-27-48-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=2&screen-shot-2020-04-19-at-1-27-48-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=2&screen-shot-2020-04-19-at-1-27-48-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 3" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=3&screen-shot-2020-04-19-at-1-33-56-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=3&screen-shot-2020-04-19-at-1-33-56-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=3&screen-shot-2020-04-19-at-1-33-56-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=3&screen-shot-2020-04-19-at-1-33-56-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 4" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=4&screen-shot-2020-04-19-at-2-48-12-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=4&screen-shot-2020-04-19-at-2-48-12-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=4&screen-shot-2020-04-19-at-2-48-12-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=4&screen-shot-2020-04-19-at-2-48-12-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 5" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=5&screen-shot-2020-04-19-at-1-35-20-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=5&screen-shot-2020-04-19-at-1-35-20-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=5&screen-shot-2020-04-19-at-1-35-20-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=5&screen-shot-2020-04-19-at-1-35-20-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 6" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=6&screen-shot-2020-04-19-at-1-35-20-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=6&screen-shot-2020-04-19-at-1-35-20-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=6&screen-shot-2020-04-19-at-1-35-20-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=6&screen-shot-2020-04-19-at-1-35-20-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 7" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=7&screen-shot-2020-04-19-at-2-49-26-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=7&screen-shot-2020-04-19-at-2-49-26-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=7&screen-shot-2020-04-19-at-2-49-26-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=7&screen-shot-2020-04-19-at-2-49-26-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 8" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=8&screen-shot-2020-04-19-at-1-34-33-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=8&screen-shot-2020-04-19-at-1-34-33-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=8&screen-shot-2020-04-19-at-1-34-33-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=8&screen-shot-2020-04-19-at-1-34-33-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 9" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=9&screen-shot-2020-04-19-at-1-34-43-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=9&screen-shot-2020-04-19-at-1-34-43-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=9&screen-shot-2020-04-19-at-1-34-43-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=9&screen-shot-2020-04-19-at-1-34-43-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 10" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=10&screen-shot-2020-04-19-at-1-34-57-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=10&screen-shot-2020-04-19-at-1-34-57-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=10&screen-shot-2020-04-19-at-1-34-57-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=10&screen-shot-2020-04-19-at-1-34-57-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 11" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=11&screen-shot-2020-04-19-at-2-48-43-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=11&screen-shot-2020-04-19-at-2-48-43-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=11&screen-shot-2020-04-19-at-2-48-43-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=11&screen-shot-2020-04-19-at-2-48-43-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 12" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=12&screen-shot-2020-04-19-at-1-30-02-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=12&screen-shot-2020-04-19-at-1-30-02-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=12&screen-shot-2020-04-19-at-1-30-02-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=12&screen-shot-2020-04-19-at-1-30-02-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 13" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=13&screen-shot-2020-04-19-at-1-30-09-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=13&screen-shot-2020-04-19-at-1-30-09-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=13&screen-shot-2020-04-19-at-1-30-09-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=13&screen-shot-2020-04-19-at-1-30-09-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 14" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=14&screen-shot-2020-04-19-at-1-30-29-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=14&screen-shot-2020-04-19-at-1-30-29-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=14&screen-shot-2020-04-19-at-1-30-29-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=14&screen-shot-2020-04-19-at-1-30-29-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 15" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=15&screen-shot-2020-04-19-at-1-31-41-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=15&screen-shot-2020-04-19-at-1-31-41-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=15&screen-shot-2020-04-19-at-1-31-41-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=15&screen-shot-2020-04-19-at-1-31-41-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 16" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=16&screen-shot-2020-04-19-at-1-31-41-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=16&screen-shot-2020-04-19-at-1-31-41-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=16&screen-shot-2020-04-19-at-1-31-41-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=16&screen-shot-2020-04-19-at-1-31-41-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 17" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=17&screen-shot-2020-04-19-at-1-31-48-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=17&screen-shot-2020-04-19-at-1-31-48-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=17&screen-shot-2020-04-19-at-1-31-48-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=17&screen-shot-2020-04-19-at-1-31-48-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 18" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=18&screen-shot-2020-04-19-at-1-32-04-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=18&screen-shot-2020-04-19-at-1-32-04-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=18&screen-shot-2020-04-19-at-1-32-04-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=18&screen-shot-2020-04-19-at-1-32-04-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 19" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=19&screen-shot-2020-04-19-at-1-32-39-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=19&screen-shot-2020-04-19-at-1-32-39-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=19&screen-shot-2020-04-19-at-1-32-39-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=19&screen-shot-2020-04-19-at-1-32-39-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 20" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=20&screen-shot-2020-04-19-at-1-33-08-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=20&screen-shot-2020-04-19-at-1-33-08-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=20&screen-shot-2020-04-19-at-1-33-08-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=20&screen-shot-2020-04-19-at-1-33-08-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 21" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=21&screen-shot-2020-04-19-at-1-33-17-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=21&screen-shot-2020-04-19-at-1-33-17-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=21&screen-shot-2020-04-19-at-1-33-17-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=21&screen-shot-2020-04-19-at-1-33-17-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 22" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=22&screen-shot-2020-04-19-at-1-33-26-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=22&screen-shot-2020-04-19-at-1-33-26-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=22&screen-shot-2020-04-19-at-1-33-26-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=22&screen-shot-2020-04-19-at-1-33-26-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 23" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=23&screen-shot-2020-04-19-at-1-33-41-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=23&screen-shot-2020-04-19-at-1-33-41-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=23&screen-shot-2020-04-19-at-1-33-41-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=23&screen-shot-2020-04-19-at-1-33-41-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 24" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=24&screen-shot-2020-04-19-at-1-34-22-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=24&screen-shot-2020-04-19-at-1-34-22-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=24&screen-shot-2020-04-19-at-1-34-22-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=24&screen-shot-2020-04-19-at-1-34-22-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 25" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=25&screen-shot-2020-04-19-at-1-36-09-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=25&screen-shot-2020-04-19-at-1-36-09-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=25&screen-shot-2020-04-19-at-1-36-09-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=25&screen-shot-2020-04-19-at-1-36-09-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 26" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=26&screen-shot-2020-04-19-at-1-36-09-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=26&screen-shot-2020-04-19-at-1-36-09-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=26&screen-shot-2020-04-19-at-1-36-09-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=26&screen-shot-2020-04-19-at-1-36-09-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 27" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=27&screen-shot-2020-04-19-at-1-36-20-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=27&screen-shot-2020-04-19-at-1-36-20-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=27&screen-shot-2020-04-19-at-1-36-20-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=27&screen-shot-2020-04-19-at-1-36-20-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 28" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=28&screen-shot-2020-04-19-at-1-27-26-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=28&screen-shot-2020-04-19-at-1-27-26-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=28&screen-shot-2020-04-19-at-1-27-26-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=28&screen-shot-2020-04-19-at-1-27-26-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 29" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=29&screen-shot-2020-04-19-at-1-27-56-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=29&screen-shot-2020-04-19-at-1-27-56-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=29&screen-shot-2020-04-19-at-1-27-56-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=29&screen-shot-2020-04-19-at-1-27-56-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 30" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=30&screen-shot-2020-04-19-at-1-28-05-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=30&screen-shot-2020-04-19-at-1-28-05-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=30&screen-shot-2020-04-19-at-1-28-05-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=30&screen-shot-2020-04-19-at-1-28-05-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 31" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=31&screen-shot-2020-04-19-at-1-28-33-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=31&screen-shot-2020-04-19-at-1-28-33-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=31&screen-shot-2020-04-19-at-1-28-33-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=31&screen-shot-2020-04-19-at-1-28-33-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 32" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=32&screen-shot-2020-04-19-at-1-29-47-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=32&screen-shot-2020-04-19-at-1-29-47-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=32&screen-shot-2020-04-19-at-1-29-47-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=32&screen-shot-2020-04-19-at-1-29-47-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 33" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=33&screen-shot-2020-04-19-at-1-29-02-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=33&screen-shot-2020-04-19-at-1-29-02-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=33&screen-shot-2020-04-19-at-1-29-02-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=33&screen-shot-2020-04-19-at-1-29-02-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 34" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=34&screen-shot-2020-04-19-at-1-29-13-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=34&screen-shot-2020-04-19-at-1-29-13-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=34&screen-shot-2020-04-19-at-1-29-13-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=34&screen-shot-2020-04-19-at-1-29-13-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 35" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=35&screen-shot-2020-04-19-at-1-29-22-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=35&screen-shot-2020-04-19-at-1-29-22-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=35&screen-shot-2020-04-19-at-1-29-22-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=35&screen-shot-2020-04-19-at-1-29-22-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 36" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=36&screen-shot-2020-04-19-at-1-29-22-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=36&screen-shot-2020-04-19-at-1-29-22-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=36&screen-shot-2020-04-19-at-1-29-22-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=36&screen-shot-2020-04-19-at-1-29-22-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 37" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=37&screen-shot-2020-04-19-at-1-29-35-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=37&screen-shot-2020-04-19-at-1-29-35-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=37&screen-shot-2020-04-19-at-1-29-35-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=37&screen-shot-2020-04-19-at-1-29-35-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 38" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=38&screen-shot-2020-04-19-at-1-31-18-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=38&screen-shot-2020-04-19-at-1-31-18-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=38&screen-shot-2020-04-19-at-1-31-18-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=38&screen-shot-2020-04-19-at-1-31-18-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 39" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=39&screen-shot-2020-04-19-at-1-34-14-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=39&screen-shot-2020-04-19-at-1-34-14-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=39&screen-shot-2020-04-19-at-1-34-14-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=39&screen-shot-2020-04-19-at-1-34-14-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 40" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=40&screen-shot-2020-04-19-at-1-35-41-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=40&screen-shot-2020-04-19-at-1-35-41-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=40&screen-shot-2020-04-19-at-1-35-41-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=40&screen-shot-2020-04-19-at-1-35-41-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 41" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=41&screen-shot-2020-04-19-at-1-35-57-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=41&screen-shot-2020-04-19-at-1-35-57-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=41&screen-shot-2020-04-19-at-1-35-57-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=41&screen-shot-2020-04-19-at-1-35-57-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 42" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=42&screen-shot-2020-04-19-at-1-36-29-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=42&screen-shot-2020-04-19-at-1-36-29-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=42&screen-shot-2020-04-19-at-1-36-29-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=42&screen-shot-2020-04-19-at-1-36-29-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 43" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=43&screen-shot-2020-04-19-at-1-36-38-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=43&screen-shot-2020-04-19-at-1-36-38-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=43&screen-shot-2020-04-19-at-1-36-38-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=43&screen-shot-2020-04-19-at-1-36-38-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 44" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=44&screen-shot-2020-04-19-at-1-36-53-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=44&screen-shot-2020-04-19-at-1-36-53-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=44&screen-shot-2020-04-19-at-1-36-53-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=44&screen-shot-2020-04-19-at-1-36-53-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 45" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=45&screen-shot-2020-04-19-at-1-37-00-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=45&screen-shot-2020-04-19-at-1-37-00-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=45&screen-shot-2020-04-19-at-1-37-00-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=45&screen-shot-2020-04-19-at-1-37-00-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 46" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=46&screen-shot-2020-04-19-at-1-37-00-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=46&screen-shot-2020-04-19-at-1-37-00-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=46&screen-shot-2020-04-19-at-1-37-00-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=46&screen-shot-2020-04-19-at-1-37-00-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 47" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=47&screen-shot-2020-04-19-at-2-48-29-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=47&screen-shot-2020-04-19-at-2-48-29-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=47&screen-shot-2020-04-19-at-2-48-29-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=47&screen-shot-2020-04-19-at-2-48-29-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 48" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=48&screen-shot-2020-04-19-at-2-49-47-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=48&screen-shot-2020-04-19-at-2-49-47-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=48&screen-shot-2020-04-19-at-2-49-47-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=48&screen-shot-2020-04-19-at-2-49-47-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 49" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=49&screen-shot-2020-04-19-at-2-50-18-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=49&screen-shot-2020-04-19-at-2-50-18-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=49&screen-shot-2020-04-19-at-2-50-18-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=49&screen-shot-2020-04-19-at-2-50-18-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 50" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=50&screen-shot-2020-04-19-at-1-28-41-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=50&screen-shot-2020-04-19-at-1-28-41-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=50&screen-shot-2020-04-19-at-1-28-41-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=50&screen-shot-2020-04-19-at-1-28-41-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 51" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=51&screen-shot-2020-04-19-at-1-29-54-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=51&screen-shot-2020-04-19-at-1-29-54-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=51&screen-shot-2020-04-19-at-1-29-54-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=51&screen-shot-2020-04-19-at-1-29-54-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 52" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=52&screen-shot-2020-04-19-at-1-30-16-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=52&screen-shot-2020-04-19-at-1-30-16-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=52&screen-shot-2020-04-19-at-1-30-16-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=52&screen-shot-2020-04-19-at-1-30-16-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 53" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=53&screen-shot-2020-04-19-at-1-30-53-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=53&screen-shot-2020-04-19-at-1-30-53-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=53&screen-shot-2020-04-19-at-1-30-53-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=53&screen-shot-2020-04-19-at-1-30-53-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 54" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=54&screen-shot-2020-04-19-at-1-33-00-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=54&screen-shot-2020-04-19-at-1-33-00-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=54&screen-shot-2020-04-19-at-1-33-00-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=54&screen-shot-2020-04-19-at-1-33-00-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 55" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=55&screen-shot-2020-04-19-at-1-35-49-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=55&screen-shot-2020-04-19-at-1-35-49-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=55&screen-shot-2020-04-19-at-1-35-49-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=55&screen-shot-2020-04-19-at-1-35-49-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 56" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=56&screen-shot-2020-04-19-at-1-35-49-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=56&screen-shot-2020-04-19-at-1-35-49-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=56&screen-shot-2020-04-19-at-1-35-49-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=56&screen-shot-2020-04-19-at-1-35-49-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 57" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=57&screen-shot-2020-04-19-at-1-36-46-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=57&screen-shot-2020-04-19-at-1-36-46-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=57&screen-shot-2020-04-19-at-1-36-46-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=57&screen-shot-2020-04-19-at-1-36-46-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 58" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=58&screen-shot-2020-04-19-at-1-35-32-pm&amp;locale=en_US&amp;t=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=58&screen-shot-2020-04-19-at-1-35-32-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="The funniest #FloridaMorons tweets, as Florida's beaches reopened" data-url="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=58&screen-shot-2020-04-19-at-1-35-32-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=58&screen-shot-2020-04-19-at-1-35-32-pm&amp;media=https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000.jpg&amp;description=The funniest #FloridaMorons tweets, as Florida's beaches reopened" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div> </div>
<div class="slide-nav">
<span class="prev">Prev</span>
<div class="photo-progress"></div>
<span class="next">Next</span>
</div>

<div class="photo-slider" itemscope itemtype="http://schema.org/ImageGallery">
<div id="div-gpt-ad-orl_300x250-3_container" style="display: none" class="inline">
<div id="div-gpt-ad-orl_300x250-3"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_300x250-3'); });</script></div> </div>
<img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.38-PM.jpg" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.38-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-30-38-pm" data-width="728" data-height="486" rel="1" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.27.48-PM.jpg" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.27.48-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-27-48-pm" data-width="728" data-height="488" rel="2" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.56-PM.jpg" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.56-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-33-56-pm" data-width="728" data-height="484" rel="3" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.48.12-PM.jpg" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.48.12-PM.jpg" data-postname="screen-shot-2020-04-19-at-2-48-12-pm" data-width="728" data-height="516" rel="4" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.35.20-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-35-20-pm" data-width="728" data-height="776" rel="5" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="6" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.49.26-PM.jpg" data-postname="screen-shot-2020-04-19-at-2-49-26-pm" data-width="728" data-height="632" rel="7" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.34.33-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-34-33-pm" data-width="728" data-height="482" rel="8" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.34.43-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-34-43-pm" data-width="728" data-height="617" rel="9" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.34.57-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-34-57-pm" data-width="728" data-height="506" rel="10" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.48.43-PM.jpg" data-postname="screen-shot-2020-04-19-at-2-48-43-pm" data-width="728" data-height="650" rel="11" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.02-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-30-02-pm" data-width="728" data-height="566" rel="12" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.09-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-30-09-pm" data-width="728" data-height="658" rel="13" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.29-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-30-29-pm" data-width="728" data-height="644" rel="14" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.31.41-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-31-41-pm" data-width="728" data-height="480" rel="15" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="16" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.31.48-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-31-48-pm" data-width="728" data-height="537" rel="17" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.32.04-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-32-04-pm" data-width="728" data-height="632" rel="18" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.32.39-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-32-39-pm" data-width="728" data-height="847" rel="19" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.08-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-33-08-pm" data-width="728" data-height="529" rel="20" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.17-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-33-17-pm" data-width="728" data-height="776" rel="21" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.26-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-33-26-pm" data-width="728" data-height="448" rel="22" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.41-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-33-41-pm" data-width="728" data-height="590" rel="23" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.34.22-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-34-22-pm" data-width="728" data-height="455" rel="24" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.36.09-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-36-09-pm" data-width="728" data-height="487" rel="25" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="26" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.36.20-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-36-20-pm" data-width="728" data-height="593" rel="27" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.27.26-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-27-26-pm" data-width="728" data-height="534" rel="28" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.27.56-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-27-56-pm" data-width="728" data-height="559" rel="29" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.28.05-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-28-05-pm" data-width="728" data-height="617" rel="30" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.28.33-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-28-33-pm" data-width="728" data-height="820" rel="31" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.29.47-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-29-47-pm" data-width="728" data-height="487" rel="32" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.29.02-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-29-02-pm" data-width="728" data-height="539" rel="33" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.29.13-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-29-13-pm" data-width="728" data-height="576" rel="34" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.29.22-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-29-22-pm" data-width="728" data-height="535" rel="35" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="36" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.29.35-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-29-35-pm" data-width="728" data-height="608" rel="37" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.31.18-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-31-18-pm" data-width="728" data-height="612" rel="38" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.34.14-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-34-14-pm" data-width="728" data-height="606" rel="39" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.35.41-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-35-41-pm" data-width="728" data-height="480" rel="40" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.35.57-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-35-57-pm" data-width="728" data-height="490" rel="41" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.36.29-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-36-29-pm" data-width="728" data-height="568" rel="42" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.36.38-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-36-38-pm" data-width="728" data-height="444" rel="43" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.36.53-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-36-53-pm" data-width="728" data-height="481" rel="44" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.37.00-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-37-00-pm" data-width="728" data-height="620" rel="45" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="46" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.48.29-PM.jpg" data-postname="screen-shot-2020-04-19-at-2-48-29-pm" data-width="728" data-height="515" rel="47" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.49.47-PM.jpg" data-postname="screen-shot-2020-04-19-at-2-49-47-pm" data-width="728" data-height="725" rel="48" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-2.50.18-PM.jpg" data-postname="screen-shot-2020-04-19-at-2-50-18-pm" data-width="728" data-height="542" rel="49" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.28.41-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-28-41-pm" data-width="728" data-height="482" rel="50" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.29.54-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-29-54-pm" data-width="728" data-height="566" rel="51" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.16-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-30-16-pm" data-width="728" data-height="464" rel="52" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.30.53-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-30-53-pm" data-width="728" data-height="559" rel="53" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.33.00-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-33-00-pm" data-width="728" data-height="568" rel="54" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.35.49-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-35-49-pm" data-width="728" data-height="484" rel="55" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="56" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.36.46-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-36-46-pm" data-width="728" data-height="524" rel="57" title="" data-title="" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-19-at-1.35.32-PM.jpg" data-postname="screen-shot-2020-04-19-at-1-35-32-pm" data-width="728" data-height="168" rel="58" title="" data-title="" itemprop="image" /> </div>
<div id="slide-caption"></div>
<div class="description">
<p>Ready to hit the beach in a pandemic? Jacksonville Mayor Lenny Curry and Florida Gov. Ron DeSantis say it's safe, as long as you're walking, biking, hiking, fishing, running, swimming, taking care of pets and surfing. That's despite Florida reaching record numbers of coronavirus cases, and while much of the nation (and the world) stays home to stop the spread of COVID-19.</p>
<p>In true Florida fashion, the beaches <a href="https://www.orlandoweekly.com/Blogs/archives/2020/04/17/beaches-reopen-friday-in-jacksonville-the-most-populous-city-in-florida">did indeed reopen Friday</a>, leading the Twitterverse to weigh in – heavily. #FloridaMorons was the #1 trending topic on Twitter for much of the weekend. As beachgoers continue flocking to the northwest shores of Florida's largest city, it doesn't show any sign of slowing down – like the spread of coronavirus itself.</p>
<p>Here are some of the funniest takes out there.</p>
<p> </div>

<footer class="article-footer">
<p class="meta">Posted <time datetime="2020-04-19" pubdate>Apr. 19, 2020</time>
<span class="amp">&</span> filed under <a href="https://photos.orlandoweekly.com/category/newsslideshows/" rel="category tag">News</a>.
</p>
<div id="crumbs"><a href="https://photos.orlandoweekly.com">Home</a> &raquo; <a href="https://photos.orlandoweekly.com/category/newsslideshows/">News</a> &raquo; <span class="current">The funniest #FloridaMorons tweets, as Florida&#8217;s beaches reopened</span></div>
<p class="tags"><span class="tags-title">Tags:</span> <a href="https://photos.orlandoweekly.com/tag/coronavirus/" rel="tag">coronavirus</a>, <a href="https://photos.orlandoweekly.com/tag/covid-19/" rel="tag">COVID-19</a>, <a href="https://photos.orlandoweekly.com/tag/florida-morons/" rel="tag">Florida Morons</a>, <a href="https://photos.orlandoweekly.com/tag/floridamorons/" rel="tag">FloridaMorons</a>, <a href="https://photos.orlandoweekly.com/tag/floriduh/" rel="tag">floriduh</a>, <a href="https://photos.orlandoweekly.com/tag/jacksonville/" rel="tag">Jacksonville</a>, <a href="https://photos.orlandoweekly.com/tag/trending/" rel="tag">trending</a>, <a href="https://photos.orlandoweekly.com/tag/twitter/" rel="tag">Twitter</a></p>
<div id="div-gpt-ad-orl_728x90-2" class="bottomLeaderboard"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_728x90-2'); });</script></div>

<div id="fb-comments"></div>

<div id="div-gpt-ad-orl_desktopnative-3"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_desktopnative-3'); });</script></div>
</footer> 

<input type="hidden" id="photo-count" value="57" />
<input type="hidden" id="page-url-1" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=1&screen-shot-2020-04-19-at-1-30-38-pm" /><input type="hidden" id="image-url-1" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-30-38-pm/" /><input type="hidden" id="page-url-2" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=2&screen-shot-2020-04-19-at-1-27-48-pm" /><input type="hidden" id="image-url-2" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-27-48-pm/" /><input type="hidden" id="page-url-3" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=3&screen-shot-2020-04-19-at-1-33-56-pm" /><input type="hidden" id="image-url-3" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-33-56-pm/" /><input type="hidden" id="page-url-4" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=4&screen-shot-2020-04-19-at-2-48-12-pm" /><input type="hidden" id="image-url-4" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-2-48-12-pm/" /><input type="hidden" id="page-url-5" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=5&screen-shot-2020-04-19-at-1-35-20-pm" /><input type="hidden" id="image-url-5" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-35-20-pm/" /><input type="hidden" id="page-url-6" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=6" /><input type="hidden" id="image-url-6" value="" /><input type="hidden" id="page-url-7" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=7&screen-shot-2020-04-19-at-2-49-26-pm" /><input type="hidden" id="image-url-7" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-2-49-26-pm/" /><input type="hidden" id="page-url-8" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=8&screen-shot-2020-04-19-at-1-34-33-pm" /><input type="hidden" id="image-url-8" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-34-33-pm/" /><input type="hidden" id="page-url-9" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=9&screen-shot-2020-04-19-at-1-34-43-pm" /><input type="hidden" id="image-url-9" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-34-43-pm/" /><input type="hidden" id="page-url-10" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=10&screen-shot-2020-04-19-at-1-34-57-pm" /><input type="hidden" id="image-url-10" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-34-57-pm/" /><input type="hidden" id="page-url-11" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=11&screen-shot-2020-04-19-at-2-48-43-pm" /><input type="hidden" id="image-url-11" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-2-48-43-pm/" /><input type="hidden" id="page-url-12" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=12&screen-shot-2020-04-19-at-1-30-02-pm" /><input type="hidden" id="image-url-12" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-30-02-pm/" /><input type="hidden" id="page-url-13" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=13&screen-shot-2020-04-19-at-1-30-09-pm" /><input type="hidden" id="image-url-13" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-30-09-pm/" /><input type="hidden" id="page-url-14" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=14&screen-shot-2020-04-19-at-1-30-29-pm" /><input type="hidden" id="image-url-14" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-30-29-pm/" /><input type="hidden" id="page-url-15" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=15&screen-shot-2020-04-19-at-1-31-41-pm" /><input type="hidden" id="image-url-15" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-31-41-pm/" /><input type="hidden" id="page-url-16" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=16" /><input type="hidden" id="image-url-16" value="" /><input type="hidden" id="page-url-17" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=17&screen-shot-2020-04-19-at-1-31-48-pm" /><input type="hidden" id="image-url-17" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-31-48-pm/" /><input type="hidden" id="page-url-18" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=18&screen-shot-2020-04-19-at-1-32-04-pm" /><input type="hidden" id="image-url-18" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-32-04-pm/" /><input type="hidden" id="page-url-19" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=19&screen-shot-2020-04-19-at-1-32-39-pm" /><input type="hidden" id="image-url-19" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-32-39-pm/" /><input type="hidden" id="page-url-20" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=20&screen-shot-2020-04-19-at-1-33-08-pm" /><input type="hidden" id="image-url-20" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-33-08-pm/" /><input type="hidden" id="page-url-21" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=21&screen-shot-2020-04-19-at-1-33-17-pm" /><input type="hidden" id="image-url-21" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-33-17-pm/" /><input type="hidden" id="page-url-22" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=22&screen-shot-2020-04-19-at-1-33-26-pm" /><input type="hidden" id="image-url-22" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-33-26-pm/" /><input type="hidden" id="page-url-23" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=23&screen-shot-2020-04-19-at-1-33-41-pm" /><input type="hidden" id="image-url-23" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-33-41-pm/" /><input type="hidden" id="page-url-24" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=24&screen-shot-2020-04-19-at-1-34-22-pm" /><input type="hidden" id="image-url-24" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-34-22-pm/" /><input type="hidden" id="page-url-25" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=25&screen-shot-2020-04-19-at-1-36-09-pm" /><input type="hidden" id="image-url-25" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-36-09-pm/" /><input type="hidden" id="page-url-26" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=26" /><input type="hidden" id="image-url-26" value="" /><input type="hidden" id="page-url-27" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=27&screen-shot-2020-04-19-at-1-36-20-pm" /><input type="hidden" id="image-url-27" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-36-20-pm/" /><input type="hidden" id="page-url-28" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=28&screen-shot-2020-04-19-at-1-27-26-pm" /><input type="hidden" id="image-url-28" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-27-26-pm/" /><input type="hidden" id="page-url-29" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=29&screen-shot-2020-04-19-at-1-27-56-pm" /><input type="hidden" id="image-url-29" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-27-56-pm/" /><input type="hidden" id="page-url-30" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=30&screen-shot-2020-04-19-at-1-28-05-pm" /><input type="hidden" id="image-url-30" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-28-05-pm/" /><input type="hidden" id="page-url-31" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=31&screen-shot-2020-04-19-at-1-28-33-pm" /><input type="hidden" id="image-url-31" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-28-33-pm/" /><input type="hidden" id="page-url-32" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=32&screen-shot-2020-04-19-at-1-29-47-pm" /><input type="hidden" id="image-url-32" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-29-47-pm/" /><input type="hidden" id="page-url-33" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=33&screen-shot-2020-04-19-at-1-29-02-pm" /><input type="hidden" id="image-url-33" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-29-02-pm/" /><input type="hidden" id="page-url-34" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=34&screen-shot-2020-04-19-at-1-29-13-pm" /><input type="hidden" id="image-url-34" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-29-13-pm/" /><input type="hidden" id="page-url-35" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=35&screen-shot-2020-04-19-at-1-29-22-pm" /><input type="hidden" id="image-url-35" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-29-22-pm/" /><input type="hidden" id="page-url-36" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=36" /><input type="hidden" id="image-url-36" value="" /><input type="hidden" id="page-url-37" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=37&screen-shot-2020-04-19-at-1-29-35-pm" /><input type="hidden" id="image-url-37" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-29-35-pm/" /><input type="hidden" id="page-url-38" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=38&screen-shot-2020-04-19-at-1-31-18-pm" /><input type="hidden" id="image-url-38" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-31-18-pm/" /><input type="hidden" id="page-url-39" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=39&screen-shot-2020-04-19-at-1-34-14-pm" /><input type="hidden" id="image-url-39" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-34-14-pm/" /><input type="hidden" id="page-url-40" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=40&screen-shot-2020-04-19-at-1-35-41-pm" /><input type="hidden" id="image-url-40" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-35-41-pm/" /><input type="hidden" id="page-url-41" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=41&screen-shot-2020-04-19-at-1-35-57-pm" /><input type="hidden" id="image-url-41" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-35-57-pm/" /><input type="hidden" id="page-url-42" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=42&screen-shot-2020-04-19-at-1-36-29-pm" /><input type="hidden" id="image-url-42" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-36-29-pm/" /><input type="hidden" id="page-url-43" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=43&screen-shot-2020-04-19-at-1-36-38-pm" /><input type="hidden" id="image-url-43" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-36-38-pm/" /><input type="hidden" id="page-url-44" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=44&screen-shot-2020-04-19-at-1-36-53-pm" /><input type="hidden" id="image-url-44" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-36-53-pm/" /><input type="hidden" id="page-url-45" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=45&screen-shot-2020-04-19-at-1-37-00-pm" /><input type="hidden" id="image-url-45" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-37-00-pm/" /><input type="hidden" id="page-url-46" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=46" /><input type="hidden" id="image-url-46" value="" /><input type="hidden" id="page-url-47" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=47&screen-shot-2020-04-19-at-2-48-29-pm" /><input type="hidden" id="image-url-47" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-2-48-29-pm/" /><input type="hidden" id="page-url-48" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=48&screen-shot-2020-04-19-at-2-49-47-pm" /><input type="hidden" id="image-url-48" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-2-49-47-pm/" /><input type="hidden" id="page-url-49" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=49&screen-shot-2020-04-19-at-2-50-18-pm" /><input type="hidden" id="image-url-49" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-2-50-18-pm/" /><input type="hidden" id="page-url-50" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=50&screen-shot-2020-04-19-at-1-28-41-pm" /><input type="hidden" id="image-url-50" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-28-41-pm/" /><input type="hidden" id="page-url-51" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=51&screen-shot-2020-04-19-at-1-29-54-pm" /><input type="hidden" id="image-url-51" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-29-54-pm/" /><input type="hidden" id="page-url-52" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=52&screen-shot-2020-04-19-at-1-30-16-pm" /><input type="hidden" id="image-url-52" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-30-16-pm/" /><input type="hidden" id="page-url-53" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=53&screen-shot-2020-04-19-at-1-30-53-pm" /><input type="hidden" id="image-url-53" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-30-53-pm/" /><input type="hidden" id="page-url-54" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=54&screen-shot-2020-04-19-at-1-33-00-pm" /><input type="hidden" id="image-url-54" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-33-00-pm/" /><input type="hidden" id="page-url-55" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=55&screen-shot-2020-04-19-at-1-35-49-pm" /><input type="hidden" id="image-url-55" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-35-49-pm/" /><input type="hidden" id="page-url-56" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=56" /><input type="hidden" id="image-url-56" value="" /><input type="hidden" id="page-url-57" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=57&screen-shot-2020-04-19-at-1-36-46-pm" /><input type="hidden" id="image-url-57" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-36-46-pm/" /><input type="hidden" id="page-url-58" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?slide=58&screen-shot-2020-04-19-at-1-35-32-pm" /><input type="hidden" id="image-url-58" value="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/screen-shot-2020-04-19-at-1-35-32-pm/" /> </div>
<div class="other-sliders">
<h2 class="viewmore" itemprop="headline">View these other slideshows:</h2>
<div class="gallery-item">
<a href="https://photos.orlandoweekly.com/this-masterpiece-historic-orlando-home-by-louis-dolive-just-hit-the-market/" title="Look This &#039;masterpiece&#039; historic Orlando home by Louis Dolive just hit the market"><img width="300" height="250" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Main-29bfefcba3942c6e9184e9823a61d87cl-m423818476xd-w1020_h770_q80-1000-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>This 'masterpiece' historic Orlando home by Louis Dolive just hit the market</h2></a>
</div>
<div class="gallery-item">
<a href="https://photos.orlandoweekly.com/former-jacksonville-jaguars-qb-nick-foles-just-listed-his-florida-dream-home/" title="Look Former Jacksonville Jaguars QB Nick Foles just listed his Florida ‘dream home’"><img width="300" height="250" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/1000-e21b6fc0d9c29fec5252d9e577d57bcal-m1440555916od-w1024_h768-copy-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>Former Jacksonville Jaguars QB Nick Foles just listed his Florida ‘dream home’</h2></a>
</div>
<div class="gallery-item">
<a href="https://photos.orlandoweekly.com/a-25-million-star-trek-themed-florida-mega-mansion-is-back-on-the-market/" title="Look This Star Trek-themed Florida mega-mansion is back on the market for $19.9 million"><img width="300" height="250" src="https://photos.orlandoweekly.com/wp-content/uploads/2019/06/Screen-Shot-2019-05-31-at-4.37.56-PM-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>This Star Trek-themed Florida mega-mansion is back on the market for $19.9 million</h2></a>
</div>
<div class="gallery-item">
<a href="https://photos.orlandoweekly.com/how-to-make-a-basic-protective-face-mask-even-if-you-cant-sew/" title="Look How to make a basic protective face mask, even if you can’t sew"><img width="300" height="250" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/DIYMASK_KaitlynHandel_Photo12-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>How to make a basic protective face mask, even if you can’t sew</h2></a>
</div>
<div class="back-to-slider">&laquo; View the previous slideshow again!</div>
</div>
</main>
</div>
<div class="col-md-4" id="sidebar-right">
<div class="support-local-journalism">
<h2>Support Local Journalism</h2>
<p>At a time when local-based reporting is critical, support from our readers is essential to our future. If you're able to, please support the <i>Orlando Weekly</i> today.</p>
<script>
        (function() {
        if(document.getElementById('commitchange-script')) return;
        var npo = 5276;
        var script = document.createElement('script');
        var first = document.getElementsByTagName('script')[0];
        script.setAttribute('data-npo-id', npo);
        script.id = 'commitchange-script';
        script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
        first.parentNode.insertBefore(script, first);
        })();
        </script>
<a data-amounts='5,10,15,25,50' class='commitchange-donate' data-hide-dedication=''></a>
</div>
<div class="medRectangle">
<div id="div-gpt-ad-orl_300x250-1"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_300x250-1'); });</script></div> </div>
<div class="gallery-teasers">
<h2 class="sectionheader">Browse Galleries</h2>
<div id="tS3" class="jThumbnailScroller">
<div class="jTscrollerContainer">
<div class="jTscroller">
<a href="https://photos.orlandoweekly.com/the-funniest-floridamorons-tweets-as-floridas-beaches-reopened/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/florida-1-1000-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>The funniest #FloridaMorons tweets, as Florida&#8217;s beaches reopened</p><a href="https://photos.orlandoweekly.com/this-masterpiece-historic-orlando-home-by-louis-dolive-just-hit-the-market/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Main-29bfefcba3942c6e9184e9823a61d87cl-m423818476xd-w1020_h770_q80-1000-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>This &#8216;masterpiece&#8217; historic Orlando home by Louis Dolive just hit the market</p><a href="https://photos.orlandoweekly.com/former-jacksonville-jaguars-qb-nick-foles-just-listed-his-florida-dream-home/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/1000-e21b6fc0d9c29fec5252d9e577d57bcal-m1440555916od-w1024_h768-copy-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>Former Jacksonville Jaguars QB Nick Foles just listed his Florida ‘dream home’</p><a href="https://photos.orlandoweekly.com/a-25-million-star-trek-themed-florida-mega-mansion-is-back-on-the-market/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.orlandoweekly.com/wp-content/uploads/2019/06/Screen-Shot-2019-05-31-at-4.37.56-PM-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>This Star Trek-themed Florida mega-mansion is back on the market for $19.9 million</p><a href="https://photos.orlandoweekly.com/how-to-make-a-basic-protective-face-mask-even-if-you-cant-sew/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/DIYMASK_KaitlynHandel_Photo12-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>How to make a basic protective face mask, even if you can’t sew</p><a href="https://photos.orlandoweekly.com/this-working-olive-farm-for-sale-in-ocala-is-even-more-beautiful-than-youd-expect/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.orlandoweekly.com/wp-content/uploads/2020/04/Main-1-4745d341534b1a5536c6f0b415adde1bl-m2113835719xd-w1020_h770_q80-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>This working olive farm for sale in Ocala is even more beautiful than you&#8217;d expect</p> </div>
</div>
<a href="#" class="jTscrollerPrevButton"></a>
<a href="#" class="jTscrollerNextButton"></a>
</div>
</div>
<div class="medRectangle">
<div id="div-gpt-ad-orl_300x250-2"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_300x250-2'); });</script></div> </div>
</div>
<script>
	/* jQuery.noConflict() for using the plugin along with other libraries.
	 You can remove it if you won't use other libraries (e.g. prototype, scriptaculous etc.) or
	 if you include jQuery before other libraries in yourdocument's head tag.
	 [more info: http://docs.jquery.com/Using_jQuery_with_Other_Libraries] */
	jQuery.noConflict();
	/* calling thumbnailScroller function with options as parameters */
	(function ( $ ) {
		window.onload = function () {
			$( "#tS3" ).thumbnailScroller( {
				scrollerType: "clickButtons",
				scrollerOrientation: "vertical",
				scrollSpeed: 2,
				scrollEasing: "easeOutCirc",
				scrollEasingAmount: 800,
				acceleration: 4,
				scrollSpeed: 800,
				noScrollCenterSpace: 10,
				autoScrolling: 0,
				autoScrollingSpeed: 2000,
				autoScrollingEasing: "easeInOutQuad",
				autoScrollingDelay: 500
			} );
		}
	})( jQuery );
</script>

</div>
</div>
<footer id="siteFooter" role="contentinfo">

<div id="FooterInfo" class="GlobalFooter FreeStuffLanding ">
<div class="footerCustomInfo col-md-4">
<h2>Orlando Weekly</h2>
<p>16 West Pine St.</p>
<p>Orlando, FL 32801</p>
<p>Phone: (407) 377-0400</p>
<p>Classified Phone: (407) 377-0415</p>
<p>Fax: (407) 377-0420</p>
</div>
<div class="footerCustomWrap col-md-8">
<div class="footerCustomNav">
<ul>
<li><a target="_top" href="http://www.orlandoweekly.com">About OW</a></li>
<li><a target="_top" href="http://www.orlandoweekly.com/orlando/Advertise/Page">Advertise</a></li>
<li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
<li><a target="_top" href="http://www.orlandoweekly.com">Work Here</a></li>
</ul>
<p>All parts of this site Copyright &copy; 2020 Orlando Weekly.</p>
</div>
</div>
<div class="clear"></div>
</div>

<div id="FooterNavigation" class="GlobalFooter Home ">
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408" target="_self">
News &amp;Features
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408" target="_self">News Home</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/first-words/Category?oid=2240418" target="_self">First Words</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/happytown/Category?oid=2240414" target="_self">Happytown</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/know-it-all/Category?oid=2240417" target="_self">Know It All</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/give-me-your-money/Category?oid=2240416" target="_self">Give Me Your Money</a></li>
<li><a href="http://www.orlandoweekly.com/Blogs/archives/bloggytown/" target="_self">Blog:
Bloggytown</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/EventSearch" target="_self">
Arts &amp;Culture
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407" target="_self">Arts &amp;Culture Home</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/visual-arts/Category?oid=2240435" target="_self">Visual Arts</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/performing-arts/Category?oid=2240436" target="_self">Performing Arts</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/books/Category?oid=2240437" target="_self">Books</a>
</li>
<li><a href="http://www.orlandoweekly.com/orlando/live-active-cultures/Category?oid=2240438" target="_self">Live Active Cultures</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/culture-2-go/Category?oid=2240439" target="_self">Culture 2 Go</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/savage-love/Category?oid=2240424" target="_self">Savage Love</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/free-will-astrology/Category?oid=2240441" target="_self">Free Will Astrology</a></li>
<li><a href="http://www.orlandoweekly.com/Blogs/archives/the-gist/" target="_self">Blog: The
Gist</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409" target="_self">
Food &amp;Drink
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409" target="_self">Food &amp;Drink Home</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/restaurant-review/Category?oid=2240450" target="_self">Restaurant Reviews</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/tip-jar/Category?oid=2240453" target="_self">Tip
Jar</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/bar-exam/Category?oid=2240455" target="_self">Bar
Exam</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/nosh-pit/Category?oid=2240452" target="_self">Nosh
Pit</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/remix/Category?oid=2240456" target="_self">Remix</a>
</li>
<li><a href="http://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258" target="_self">Find a Restaurant</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2124722" target="_self">Find a Bar or Club</a></li>
<li><a href="http://www.orlandoweekly.com/Blogs/archives/salivation-army/" target="_self">Blog:
Salivation Army</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/screens/Section?oid=2240411" target="_self">
Screens
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/screens/Section?oid=2240411" target="_self">Screens
Home</a></li>
<li>
<a href="http://www.orlandoweekly.com/orlando/movie-reviews-and-stories/Category?oid=2240471" target="_self">Movie reviews</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/couchsurfing/Category?oid=2240472" target="_self">Couchsurfing</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/music/Section?oid=2240410" target="_self">
Music
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/music/Section?oid=2240410" target="_self">Music
Home</a></li>
<li>
<a href="http://www.orlandoweekly.com/orlando/music-stories-and-interviews/Category?oid=2240462" target="_self">Music Reviews &amp;Stories</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/feedback/Category?oid=2240463" target="_self">Feedback</a>
</li>
<li><a href="http://www.orlandoweekly.com/orlando/this-little-underground/Category?oid=2240465" target="_self">This Little Underground</a></li>
<li><a href="http://www.orlandoweekly.com/Blogs/archives/orlando-music-news/" target="_self">Blog:
Orlando Music News</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/EventSearch" target="_self">Calendar</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/EventSearch" target="_self">Search Calendar
Events</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/EventSearch?feature=Staff%20Pick" target="_self">This Week's Selections</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/FreeStuff" target="_self">
Giveaways
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/FreeStuff?category=2273883">Swag</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/FreeStuff?category=2199663">Tickets</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/FreeStuff?category=2273884">Contests</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/FreeStuff?category=2273894" target="_self">
Events
</a>
</h3>
<ul class="sublinkGroup">
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413" target="_self">
Special Issues
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/annual-manual/Category?oid=2240488">Annual
Manual</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/summer-guide/Category?oid=2240491">Summer
Guide</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/bite/Category?oid=2240489">Bite</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/fall-guide/Category?oid=2240492">Fall
Guide</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/college-guide/Category?oid=2240498">College
Guide</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/drink/Category?oid=2240496">Drink</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/BestOf" target="_self">
Best of Orlando
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/BestOf?year=2014">2014</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/BestOf?year=2013">2013</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/BestOf?year=2012">2012</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/BestOf?year=2011">2011</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/ArticleArchives" target="_self">
Search
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/ArticleArchives" target="_self">Search
Articles</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/ArticleArchives" target="_self">Search
Authors</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/IssueArchives" target="_self">Search
Issues</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.orlandoweekly.com/orlando/orlando/AboutOrlandoWeekly/Page" target="_">
About Us
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.orlandoweekly.com/orlando/orlando/AboutOrlandoWeekly/Page">Staff Directory</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/orlando/Policies/Page">Policies</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/orlando/FAQs/Page">FAQ</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/orlando/AboutOrlandoWeekly/Page">Contact Us</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/orlando/WorkForUs/Page">Work for Us</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/orlando/Wheretofindus/Page">Where to Find Us</a></li>
<li><a href="http://www.orlandoweekly.com/orlando/orlando/AdvertiseWithOrlandoWeekly/Page">Advertise</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Social Media</h3>
<ul class="sublinkGroup">
<li><a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a></li>
<li><a href="https://twitter.com/OrlandoWeekly" target="_blank">Twitter</a></li>
<li><a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a></li>
</ul>
</div>
</div>
</div>

</footer>
</div>

<script type="text/javascript" async=true>
    var __cmp = (function () {
      return typeof (__cmp) == "function" ? __cmp : function (c) {
        var b = arguments;
        if (!b.length) {
          return __cmp.a;
        }
        else if (c == '__cmp')
          return false;
        else {
          if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
          }
          __cmp.a.push([].slice.apply(b));
        }
      }
    })();
    var elem = document.createElement('script');
    elem.src = "https://quantcast.mgr.consensu.org/cmp.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);

    window.__cmp('init', {
  		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Header Title Text': 'Privacy settings',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Orlando Weekly',
		'Publisher Purpose IDs': [1,2,5,4,3],
		'Post Consent Page': 'https://www.orlandoweekly.com/orlando/Policies/Page',
    });
  </script>


<link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css" />
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js"></script>
<script>

            window.addEventListener("load", function(){
        window.cookieconsent.initialise({
          "palette": {
            "popup": {
              "background": "#000000",
              "text": "#ffffff"
            },
            "button": {
              "background": "#D91F34",
              "text": "#ffffff"
            }
          },
          "position": "top",
          "content": {
            "message": "We use cookies to understand how you use our site and to improve your experience. By continuing to use our site, you accept our use of cookies, revised Privacy Policy and Terms.",
            "href": "http://www.orlandoweekly.com/orlando/orlando/Policies/Page"
          }
        })});


    </script><script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/plugins/wpsocialite/Socialite/socialite.min.js?ver=2.0'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/plugins/wpsocialite/wpsocialite.js?ver=1.0'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/plugins/wpsocialite/Socialite/extensions/socialite.pinterest.js?ver=1.0'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/js/vendor/bootstrap.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/js/main.js?ver=5.4'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/themes/euclid-slideshows-new/js/jquery.thumbnailScroller.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/js/photo-slider.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-content/plugins/photo-slider-new/js/jquery.touchSwipe.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://photos.orlandoweekly.com/wp-includes/js/wp-embed.min.js?ver=5.4'></script>
<script type="text/javascript">Socialite.setup({facebook:{lang:'en_US',appId:null},twitter:{lang:'en'},googleplus:{lang:'en'},vkontakte:{apiId:''}});</script>

<div id="div-gpt-ad-orl_desktopinterstitial"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-orl_desktopinterstitial'); });</script></div>
</body>
</html> 